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https://www.giltrex.com/


Welcome to Chordsearch 

Chordsearch is a chord reference program. 

We trust that you enjoy using this program, find it useful and that it meets your 

requirements. Any feedback both positive and negative is appreciated. Since the original 

release many of the additional features of the program, have been as a result of 

suggestions received from users. 

 

Chordsearch was originally released as an MS-DOS program and was later superseded by 

this Windows version. 

It was originally marketed as a shareware program.  

Since version 1.40 it has been a freeware program.  

Going forward the intention is to release this program as open source software. 

 

Help to support this software 

 

Many thanks all those who have donated. It really does make a difference! Such donations 

are very much appreciated and provides the inspiration to continue maintaining and 

enhancing this program.  

Aside from our appreciation - we will always be willing to help with support and be open to 

any suggestions for new features from donors. (For those who bought Chordsearch as 

shareware in the past we will of course be happy to continue to provide support.) 

Donation page 

 

 

https://www.giltrex.com/donate/


System Requirements 

IBM PC or compatible personal computer.  

Operating Systems: Windows 10 / 11 

 

 



Overview of Chordsearch 

 

The program has been designed with the intention of giving the guitarist who has 

progressed past fundamental chord theory, access to an extremely wide variety of chord 

inversions. 

Features include:  

o Search on any conceivable chord, displaying many inversions of chord found.  

o Change tuning to any alternate tuning desired.  

o Chord directory with over 400 chord names accessing 10000 plus chord shapes.  

o Web publishing - save screen displays to HTML, plus load for editing. 

o Chord history buffer. 

o Scratch Pad for custom modification of chord attributes etc. 

o Play chords through a sound card.  

o Print out screen displays.  

o Custom chord directory.  



License Agreement 

Freeware Licence Agreement 

Chordsearch is provided as Freeware for personal and commercial use. 

 

1. Rights: You are granted a non-exclusive license to use this software on any number of 

computers. You may redistribute this software provided that the original package remains 

intact. 

 

2. Restrictions: You may not rent, lease, or sell this software for profit. Reverse 

engineering or decompilation is prohibited. 

 

3. Disclaimer of Warranty: THIS SOFTWARE IS PROVIDED "AS IS" AND ANY 

EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 

IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 

PURPOSE ARE DISCLAIMED. 

 

4. Limitation of Liability: IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY 

DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 

DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE 

GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 

INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 

WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 

OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, 

EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

 

 

 

Sound Blaster AWE32 and Sound Blaster 16 are trademarks of Creative Technology Ltd. 

Dell is a registered trademark of Dell Computer Corporation. Chordsearch is a trademark of 

Giltrex Ltd. Intel, Pentium are registered trademarks of Intel Corporation. IBM and AT are 



registered trademarks and PC/XT are trademarks of International Business Machines 

Corporation. Microsoft, MS, MS-DOS are registered trademarks and Windows, Win32, 

Windows 10/11 are trademarks of Microsoft Corporation. Firefox is a trademark of The 

Mozilla Foundation. Netscape Communicator is a trademark of Netscape Communications 

Corporation. Java is a registered trademark of Sun Microsystems. All other products are 

registered trademarks or trademarks of their respective owners. 

 



Uninstall 

As part of the installation setup, an uninstall icon is added to the Chordsearch folder. Run 

this to remove Chordsearch from your system. (You may also uninstall via Control Panel -> 

Add or Remove Programs.) 

 

 



A step by step guide 
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Chordsearch 

In any normal chord book a line has to be drawn as to just how many chords can be listed. 

Often the more adventurous guitarist starts exploring more diverse chords. This is just 

where Chordsearch comes into its own. Choose Chordsearch from the Search menu to 

display the Chordsearch dialog box. To search for a particular chord check the notes that 

make up the chord. By choosing OK the inversions for that chord will be found and 

displayed on screen. For obvious reasons the maximum number of notes that may be 

selected in the Chordsearch dialog box are six. If the chord searched for is recognised as 

one of those in the chord directory or the custom directory, then the chord name will be 

displayed, otherwise "No chord i.d. found" will be displayed. The chord name is shown 

above the chords displayed as well as being displayed in the caption bar and the status bar. 

It should be noted that in the instance where there is more than one name for the chord, the 

names will be separated by a colon. (e.g. "A dim:C dim:Eb dim:F# dim") The number of 

inversions of the chord is shown in the status bar to the right of the tuning status.  



Chord Directories 

 

This lists over 400 chord names giving easy access to a wide range of chord inversions for 

each chord name, opening up many new shapes for familiar and not so familiar chords. 

Choose Chord Directory from the Search menu to display the Chord Directory dialog box. 

To look up a particular chord use the UP and DOWN push buttons to go to the particular 'list 

box root' of the chord. Then scroll through the listbox and select the chord by highlighting 

the chord name and then press the OK button or double click on the chord name. For 

example to look up E 13th minor ninth. If on entering the Chord Directory the chords listed 

are A major through to A 13th minor 9th diminished 5th hit the UP button 7 times (or DOWN 

button 5 times) to display the listbox with E major as the first entry. Then scroll down the list 

box until E 13th minor ninth is in view; highlight the selection and double click or press OK. 

The chord will then be displayed. On returning to the chord directory dialog box again E 

13th minor ninth will be highlighted as the last chord looked up. 

A point to note is that all the chords accessed through the Chord Directory access and 

display only those chords that contain all the notes that make up the chord. This may seem 

obvious, but it is a practice in some chord books to show and label chords that do not 

contain all the constituent notes; this particularly applies to chords with five or six 

constituent notes (e.g. G13-9 etc.) 

 

Access to custom directory. Choose User Directory from the Search menu to display the 

User Directory dialog box. This allows the user to build their own custom directory of chords 

not contained in the standard directory, which they may frequently access.  

 



Viewing Pages, Fretboard and Scratchpad 

 

The number of inversions for some chords looked up via Chordsearch or through the 

Directory will be such that they will be displayed on more than one page. For example, 

looking up A eleventh (with reduced span off) will return 75 inversions. If the size is set at 6 

chords per row then 3 pages will be set up, the display initially being on page 1. To go to the 

next page(page 2) select View -> Next Page. To go back to the previous page(page 1) 

select View -> Previous Page. To go to the last page(page 3) select View -> Last Page. To 

go back to the first page(page 1) select View -> First Page. The number of pages is 

dependant on the Scale Size/chords per row. If in the above example the scale size is 

changed from 6 to 3 then the number of pages increases from 3 to 9, reflecting the fact that 

on Size 3, 9 chords can be displayed on each page (3 rows by 3 columns) as opposed to 

Size 6 for which 36 chords can be displayed (6 rows by 6 columns).  

 

  

Toolbar Shortcuts:  

 View first page of chord display. 

 View previous page of chord display. 

 View next page of chord display. 

 View last page of chord display. 

 

 

For normal operation the Chord Display option in the View is selected/ticked(plus Scratch 

Pad not selected). If you wish to view the Fretboard select Fretboard from the View menu. 

This option is particularly useful when a non standard tuning has been selected.  

If a chord has been selected(i.e. shown in Window Title and Status Bar) the fretboard will 

show only the notes for that chord. If you wish to view all the notes on the fretboard then 



select Clear from the View menu to view all the notes. This action erases the current chord 

stored in memory. 

Note: On printing fretboard in scale size 3 and 4 Landscape needs to be set. 

Toolbar Shortcut: 

 

 

Having marked and copied some chords to the Scratch Pad(ref. Copying chords to Scratch 

Pad), to view the Scratch Pad select Scratch Pad from the View menu. You can now edit 

the chord attributes etc. for the chords stored in the Scratch Pad(ref. Editing Attributes of 

Scratch Pad Chords). 

Note: On selecting Scratch Pad Search, Change Tuning, Reduced Span etc. are disabled.  

Toolbar Shortcut: 

 

 

 

 

 



Customizing Display 

 

Selecting Toolbar from the View menu toggles the toolbar on and off . The toolbar contains 

a useful selection of buttons that provide a fast means of carrying out an action. For 

example the third button is a picture of a torch, which represents using the Chordsearch 

operation. Pressing this button is quicker than choosing Chordsearch from the Search 

menu. Whilst the mouse pointer is over the button a tip 'Chordsearch' is displayed in the 

immediate vicinity, in addition to a more detailed tip being displayed in the Status Bar. 

 

Selecting Status bar from the View menu toggles the status bar on and off. The Status bar 

contains a useful selection of information. 

The left area of the status bar describes actions of menu items as you use the arrow keys to 

navigate through menus. This area similarly shows messages that describe the actions of 

toolbar buttons as you depress them, before releasing them. If after viewing the description 

of the toolbar button command you wish not to execute the command, then release the 

mouse button while the pointer is off the toolbar button.  

The next area displays the chord name currently selected.  

The next area displays the Tuning status plus the number of inversions of the chord 

currently selected, plus the page. 

The right areas of the status bar indicate which of the following keys are latched down:  

Indicator Description  

CAP The Caps Lock key is latched down.  

NUM The Num Lock key is latched down.  

SCRL The Scroll Lock key is latched down. 

 

Selecting Size from the View menu allows the setting of the scale sizing. The scale can be 

from the largest 3 chords per row, through to the smallest 6 chords per row Chord display, 



with 4 and 5 as interim widths. The combo box on the toolbar provides a fast method for 

changing the size. 

 

Choose Options from the Tools menu to select the Options tabbed dialog - select General 

page. 

Selecting Reduced from the Filter group box allows the reduction of the span of the chords 

selected. The chord displays for up to and including the 7th fret position cover a maximum 

span of 4 frets. Past the 7th fret position the chord displays cover a maximum span of 5 

frets. Select this option should you wish to reduce the respective spans by 1 fret (i.e. Up to 

and inc. 7th fret maximum span = 3 frets; past 7th fret maximum span = 4 frets).  

 

 

 

 

Choose Options from the Tools menu to select the Options tabbed dialog - select Display 

page. 

Tick Notes Colour for separate colours for each distinct note. i.e. A - dark blue, A# - bright 

blue etc. 

 

 

 

Choose Options from the Tools menu to select the Options tabbed dialog - select Display 

page. Tick Notes on frets to display the notes on the fretboard for the chord grid as opposed 

to the more usual finger position circles on the frets with the notes shown at the bottom of 

the chord grid.  

 

Note: For viewing the fretboard, the notes are always displayed on the fretboard.  



 

 

Choose Language from the Tools menu to select the Language Options dialog box. This 

allows the selection of German Language preference for the display of note symbols. 

 

 

 

 



Change Tuning 

There is the facility to adjust the tuning for the chords displayed. By default the tuning is 

initially set as regular E A D G B E. By selecting Options from the Tools menu to select the 

Options tabbed dialog - select Tuning page, which lets you set the tuning. 

 



Using the Scratchpad 

 

The Scratch Pad is a facility whereby chord frames can be marked in the chord display 

mode and transferred to the Scratch Pad where the individual chord attributes can then be 

modified prior to saving to an HTML file or printing. This facility is particularly useful when it 

comes to publishing on the web. For example if you wished to publish a short page of 

chords for the novice, you could mark open C, open E, F at the first fret and open G, 

copying these in turn to the Scratch Pad. On selecting the Scratch Pad you now have the 

opportunity to edit the attributes of each chord(ref.: Editing Attributes of Scratch Pad 

Chords) prior to saving the page to an HTML file. For example as this page is for the novice 

you might choose to modify F, and remove the finger positions for the 5th and 6th string, 

thus making it easier to play. 

Copying chords to Scratch Pad  

 

Cut chords from Scratch Pad  

 

Editing Attributes of Scratch Pad Chords  

 

Scratch Pad Options  

 



Saving and publishing HTML pages 

 

 

 

 

Chordsearch has the facility to save the chord and fretboard displays to HTML files with a 

link to a pdf file. (Using the "print to save to PDF" facility.)  

[For earlier versions of Chordsearch a java applet ChordSearch_App.class was included 

which drew the graphics for the chord frames and finger positions. Current modern 

browsers discontinued support for Java applets due to security concerns. Ref.: Migrating 

from Java Applets to plugin-free Java technologies.] 

 

Saving Display to HTML File 

 

Loading a previously saved HTML File 

 

HTML Format options 

 

A guide to publishing your chord pages on the web 

 

https://www.oracle.com/technetwork/java/javase/migratingfromapplets-2872444.pdf
https://www.oracle.com/technetwork/java/javase/migratingfromapplets-2872444.pdf


History Buffer 

 

When enabled the history buffer allows the facility to go through previously selected Chord 

Pages, by the use of the Forward and Back buttons, in a similar fashion to forward and back 

buttons on a web browser such as Brave, Chrome, Firefox etc.. The history buffer may be 

enabled and configured by choosing Options from the Tools menu to select the General 

tabbed dialog 

On history buffer being enabled to navigate through chord pages: 

Back command (View menu) 

Move back to the previous chord stored in the chord history buffer. 

 

Toolbar:   

Forward command (View menu) 

Move forward to the previous chord stored in the chord history buffer. 

 

Toolbar:   

Start History command (View menu) 

Move to the first chord stored in the chord history buffer. 

End History command (View menu) 

Move to the last chord stored in the chord history buffer. 

To clear the history buffer - select View -> Clear All, which clears the history buffer as well 

as any active chord screen display. 

 



Configuring the Sound Output Device 

Choose Options from the Tools menu to select the Options tabbed dialog - select MIDI Out 

tabbed dialog.  

The Output Device combo box allows the selection of the appropriate output device specific 

to your sound card. For example with the Sound Blaster 16 bit Audio Card there are two 

options: Sound Blaster FM Synthesis and Creative Sound Blaster Midi Out which are 

fetched from the Sound Blaster 16 bit Audio Card, along with the various capabilities of 

each option: 

 

Technology  

Describes the type of output device selected.  

Number of Voices  

Voices supported by an internal synthesizer device.*  

Number of simultaneous notes  

Number of notes that can be played simultaneously by an internal synthesizer device.*  

Features  

Other features.  

 

*If device selected is a port, field has no meaning and will be set to 0.  

For the case of the Sound Blaster 16 bit Audio Card selecting Sound Blaster FM Synthesis 

is the only option to play sounds through your PCs speakers as the other option is a MIDI 

hardware port. For cards such as the Sound Blaster AWE 32 series there are further 

options. 

Virtually all modern day Windows PCs include an integrated (onboard) sound card — rather 

than a discrete add-in sound card, (such as the Sound Blaster 16 bit Audio Card above). 

The dominant provider is Realtek. The integrated audio solution follows the Intel High 

Definition Audio (HDA) specification. 

A typically output device will display :"Microsoft GS Wavetable Synth" Number voices: 32 

Number of simultaneous voices: 32 



On clicking OK to close the dialog box the option selected is saved for this and subsequent 

sessions. 

 

 

 



Printing 

 

 

Choose Print from the File menu to print a document. This command presents a Print dialog 

box, where you may specify the range of pages to be printed, the number of copies, the 

destination printer, and other printer setup options.  

The following options allow you to specify how the document should be printed:  

Printer  

This is the active printer and printer connection. Use the combo box to change the printer.  

For publishing chords on the web, select Print to PDF. 

 

Print Range  

Specify the pages you want to print:  

All Prints the entire document. 

Selection - not used. 

Pages Prints the range of pages you specify in the From and To boxes. 

 

Print Progress Dialog  

 

The Printing dialog box is shown during the time that Chordsearch is sending output to the 

printer. The page number indicates the progress of the printing.  

 

To abort printing, choose Cancel.  

 

Shortcuts 

 



Toolbar:  

 

 Keys: CTRL+P 

 

Print Preview  

 

Choose Print Preview from the File menu to display the document as it would appear when 

printed. When you choose this command, the main window will be replaced with a print 

preview window in which one or two pages will be displayed in their printed format. The print 

preview toolbar offers you options to view either one or two pages at a time; move back and 

forth through the document; zoom in and out of pages; and initiate a print job.  

 

Print Preview toolbar  

 

The print preview toolbar offers you the following options:  

Print  

Bring up the print dialog box, to start a print job.  

Next Page  

Preview the next printed page.  

Prev Page  

Preview the previous printed page.  

One Page / Two Page  

Preview one or two printed pages at a time.  

Zoom In  

Take a closer look at the printed page.  

Zoom Out  

Take a larger look at the printed page.  



Close  

Return from print preview to the editing window.  

 

 

 

Print Setup 

 

Choose Print Setup from the File menu to select a printer and a printer connection. This 

command presents a Print Setup dialog box, where you specify the printer and its 

connection.  

 

The following options allow you to select the destination printer and its connection.  

Printer  

Select the printer you want to use. Choose the Default Printer; or choose the Specific 

Printer option and select one of the current installed printers shown in the box. You install 

printers and configure ports using the Windows Control Panel.  

Orientation  

Choose Portrait or Landscape.  

Paper Size  

Select the size of paper that the document is to be printed on.*  

Paper Source  

Some printers offer multiple trays for different paper sources. Specify the tray here.  

Options  

Displays a dialog box where you can make additional choices about printing, specific to the 

type of printer you have selected.  

Network...  

Choose this button to connect to a network location, assigning it a new drive letter.  



 

* Currently A4 is supported for a 'full page' printout.  

 



Miscellaneous 

Marking display to copy to Clipboard and Scratch Pad etc.  

 

Copying to clipboard  

 

Exit Chordsearch 

 

Use this command to end your Chordsearch session. You can also use the Close command 

on the application Control menu. 

 

Shortcuts 

 

Mouse: Double-click the application's Control menu button. 

Keys: ALT+F4 

 

 



Menus 

In This Section 

File menu commands 

Edit menu commands 

Search menu commands 

View menu commands 

Tools menu commands 

Help menu commands 

Pop up menu 



File menu commands 

The File menu offers the following commands: 

  

Load HTML to Scratch 

Pad  
Loads a previously saved HTML page into the Scratch Pad. 

Save As HTML  Saves the display to an HTML or SHTML file. 

Print Prints a document. 

Print Preview  
Displays the document on the screen as it will appear when 

printed. 

Print Setup  Selects a printer and printer connection. 

Exit  Exits Chordsearch. 

 



Edit menu commands 

The Edit menu offers the following commands: 

  

Cut from Scratch Pad Cuts marked chords from Scratch Pad. 

Copy to Clipboard Copy marked region to clipboard 

Copy to Scratch Pad Copy marked chords to Scratch Pad. 

Attributes of Scratch Pad chord  Edit attributes of marked chord in Scratch Pad. 

 



Search menu commands 

The Search menu consists of commands that let you look up a chord by entry of constituent 

notes or by selecting the chord name from the standard chord directory or the custom user 

directory. 

For more information, select the Search menu command name: 

  

Chordsearch  Enter constituent notes or mark the note positions on the fretboard. 

Chord Directory  Select chord from standard directory. 

User Directory  Select chord from custom directory. 

 



View menu commands 

The View menu offers the following commands: 

    

Toolbar Shows or hides the toolbar. 

Status Bar  Shows or hides the status bar. 

Chord Display  View Chord Display 

Fretboard View Fretboard 

Scratch Pad  View Scratch Pad 

Clear Clear Chord 

Clear All Clear All Chords 

Back View Previous chord in buffer 

Forward View Next chord in buffer 

Start History View First chord in buffer 

End History View Last chord in buffer 

First Page View First Page 

Previous Page View Previous Page 

Next Page View Next Page 

Last Page View Last Page 

Size Size 

 

    



Tools menu commands 

The Tools menu allows the setting up of various options for Chordsearch. 

For more information, select the Tools menu command name: 

  

Language  Specify language. 

Options  Select chord from standard directory. 

 



Help menu commands 

The Help menu offers the following commands, which provide you assistance with this 

application:  

  

Contents and index Displays Help Contents and Index 

Donate Go to the donation page on the Chordsearch website. 

About 

 
Displays the version number of this application. 

 

https://www.giltrex.com/donate


Pop up menu 

The following facilities are available dependent on the position of the cursor, through the 

pull right (context sensitive) "pop-up" menu (PRM): 

 

   

Cursor Position PRM options Description 

On "No chord id found" for 

unidentified chord on main 

screen. 

Add Chord to 

User Directory 

Launches Add New Chord to User 

Directory dialog box for adding Chord to 

User Directory. 

 



How To 

In This Section 

Use the mouse to sound chords 

Publishing your chords on the web. 

Marking chords to copy to Clipboard and Scratch Pad etc. 



Use the mouse to sound chords 

Sounding chords 

Having selected a chord that you wish to play. e.g. the first inversion of C major as looked 

up in the chord directory: 

 

To 'play the chord' with a downstroke, position the mouse cursor in the region bordered by 

the 1st fret, 4th fret, 6th string and 1st string and click the left mouse button. All 6 strings of 

the chord will sound starting with the 6th string and ending with the 1st string. The 

separation between the notes will be determined by the separation as set up via Tools 

Options -> Sound tabbed dialog  

To 'play the chord' with an upstroke repeat the above action except click the right mouse 

button.  

To 'play the chord' with a downstroke sounding the 5th to 1st strings only. Position the 

mouse cursor in the region bordered by the guitar nut, 1st fret, 6th string, and 5th string and 

click the left mouse button. Clicking the right mouse button will sound the 6th string. To 'play 

the chord' with a downstroke sounding the 4th to 1st strings only - position the mouse 

cursor in the region bordered by the guitar nut, 1st fret, 5th string, and 4th string and click 

the left mouse button etc. 



Publishing your chords on the web. 

Having selected and saved the chord pages to HTML (ref. Save As HTML  ) it is best to 

copy all the HTML files plus the pdf files into an empty local directory for testing. You may 

want to build a main menu page similar to the one on the Chordsearch website to link all the 

chord pages in a hierarchical structure. Once you are happy that the settings etc. are okay, 

then all that remains is to transfer the html files plus the pdf files to your web site. Please 

note if transferring via File Transfer Protocol (FTP) set the mode of transfer to binary (note 

1), as the pdf files are binary. Refer to Appendix A for further details.  

Note 1: Most GUI-based and popular FTP clients (FileZilla, Transmit, WinSCP, Cyberduck, 

many web-based or programmatic libraries, etc.) default to binary mode. 

If you do not intend publishing chords on the web, the facility to save (to html format) and 

retrieve chord pages on its own is a useful feature. 

Worked example of saving A11th for web page publication. 

Ensure reduced span switched off / unchecked [Tool -> Options -> General -> Reduced 

Span or via toolbar "r"] so as to display full 75 chords vs. 31 for reduced. 

Set scale / zoom size to 6 [View -> Size -> Chords per row or use toolbar combo box] 

Select Chord directory A eleventh. 

This will display 75 chords over 3 pages (page 1 and 2: 36 chords / page; page 3: 3 chords) 

with a title "A 11th:E min 11th:G maj 6th add 9th" 

Whilst on Page 1 select File -> Save As HTML. Leave default file name suggestion "A-11th-

E-min-11th-G-maj-6th-add-9th" and file type as HTML Files. 

If not saving to default suggested directory. Navigate to the chosen directory. 

Click Save. 

Select Print and Microsoft Print to PDF and choose (default) All for Print Range 

Click OK and for the pdf use the previously saved html file name "A-11th-E-min-11th-G-maj-

6th-add-9th" 

Click Save. 

With Windows Explorer navigate to where you saved the A-11th-E-min-11th-G-maj-6th-add-

9th.html file and double click on the file to display the chords in your default web browser. 



Note:  

* As you saved all 3 pages to the PDF file the display in your web browser will consist of 3 

distinct pages. 

* If you subsequently load the A-11th-E-min-11th-G-maj-6th-add-9th.html file into the 

scratchpad for editing etc. - only the first (active) page of 36 chords will be loaded. 

If on loading A-11th-E-min-11th-G-maj-6th-add-9th.html into your web browser the chords 

do not display, then this is likely due to a mismatch between the name of the web page and 

the pdf file. 

To fix this either rename the pdf file to match the web page: i.e. SaveChordPage.html to 

match SaveChordPage.pdf 

OR carefully edit the html file using Notepad or a dedicated html editor such as Notepad++ 

The relevant text for this example with the misnamed pdf file in red: 

<!-- <cmt> The name for the pdf is taken as the name of this html page. E.g. If 

MyChord.html pdf: MyChord.pdf </cmt> --> 

<body> 

<center><h1 style="color:#FF0000; background-color:#FFFFFF; font - family:Verdana;">A-

11th-E-min-11th-G-maj-6th-add-9th</h1></center> 

<iframe src="A-11th-E-min-11th-G-maj-6th-add-9thtypo.pdf" width="100%" 

height="800px" style="border: none; "><p>Your browser does not support PDFs. <a href = " 

<< "A-11th-E-min-11th-G-maj-6th-add-9thtypo.pdf">Download the PDF</a> instead.</p> 

</iframe> 

</body> 

For the above A-11th-E-min-11th-G-maj-6th-add-9thtypo.pdf needs to be renamed A-11th-

E-min-11th-G-maj-6th-add-9th.pdf to martch the name of the saved PDF file. 

Having corrected this error and retested in your web browser, you can then upload the html 

and pdf files to your website. 

The A-11th-E-min-11th-G-maj-6th-add-9th heading above will display as Verdana font red 

text (#FF0000) on a white background (#FFFFFF) as specified via the HTML page (Tools -> 

Options -> HTML tab) by having selected enable inline style. If this is not selected then the 

text will default to the browser default.  



If you do not select "Enable inline style" then the title header above will be saved simply as 

<h1>A-11th-E-min-11th-G-maj-6th-add-9th</h1> in which case the font and title color will 

default to the browser defaults. 

If you are experienced with html composition you may choose to update the saved page(s) 

to use Internal/External CSS: Styles defined in a <style> block in the head or in an external 

.css file.  

Note: If you do edit the html file the <meta name="info1", info2 etc. content - should not be 

touched. This will break the html file should you wish to load the page into the Chordsearch 

scratchpad for editing. 

 

 

Inline Styles (Highest Priority): Styles defined directly within the HTML tag (like your 

example) are applied last and override everything else. 

Internal/External CSS: Styles defined in a <style> block in the head or in an external .css 

file. 

Browser Defaults (Lowest Priority): The basic styling applied by browsers (like Chrome or 

Firefox) if no other styles are provided. 

The only way a CSS file can override your inline style is if the developer adds the !important 

rule to a property in the stylesheet. For example: 

/* This would override your red text from a CSS file */ 

h1 { 

color: blue !important; 

} 

Link to example webpage above. 

Link to a selection of elementary chords created using Scratchpad. 

 

https://www.giltrex.com/Chordsearch/chordsamples/A-11th-E-min-11th-G-maj-6th-add-9th.html
https://www.giltrex.com/Chordsearch/chordsamples/SelectionOfElementaryChords.html


ChordSearch_App.class (java) Deprecated 

2013 update - java security issues 

Recently there have been some security issues with the Java platform. The (java) 

ChordSearch_App.class has been withdrawn and replaced using pdf files for chord display. 

Java Security Flaws - The Register 30 Jan 2013 

Latest java update available at www.java.com 

 

September 2015 update 

Chrome no longer supports NPAPI (technology required for Java applets) 

Google's Chrome version 45 (released in September 2015) dropped support for NPAPI, 

impacting plugins for Silverlight, Java, Facebook Video and other similar NPAPI based 

plugins.  

 

 

https://www.theregister.co.uk/2013/01/30/oracle_java_security_analysis
https://www.java.com/
https://java.com/en/download/faq/chrome.xml


Marking chords to copy to Clipboard and Scratch Pad etc. 

Copy in the standard way. Press down left mouse button and drag the band around the 

region that you wish to copy. Release left button, the region then becomes inverted, and the 

copy facility is enabled  

Toolbar Shortcut: 

 

Note: Only wholly marked chords will be copied to the Scratch Pad. 

Notes:  

When in the standard chord display mode, you have the option to copy to the clipboard as 

well as the Scratch Pad. (Only wholly marked chords will be copied to the Scratch Pad.) 

When in fretboard display mode, you have the option to copy to the clipboard. 

When in the Scratch Pad display mode, you have the option to copy to the clipboard as 

cutting the selected chords from the Scratch Pad. (Only wholly marked chords will be cut 

from the Scratch Pad.) 

When marking chords to copy you must initiate the left button down action outside the chord 

frame to copy, as hitting the left button down within the chord frame is interpreted as an 

instruction to sound the chord.  
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Appendix A 

Custom chord directory 

 

The custom chord directory is stored in the file userdir.doc. When the custom chord 

directory is modified then the previous version of the custom chord directory is copied to 

userdir.bk!. Should for any reason the userdir.doc file become corrupted, then you may 

restore your previous settings by copying userdir.bk! to userdir.doc 

 

Publishing your chord pages to your web site. 

 

1. Using a web publishing package 

Nowadays using a web publishing package* makes publishing and maintaining your web 

site a lot easier. When loading up chord pages - ensure that the referenced PDF file is 

included  

* Commercial packages: 

 

  

Popular web publishing software  

1. Free and Open Source 

Content Management Systems (CMS) 

Drupal A powerful, high-end CMS used by large organizations. 

Ghost 
Mainly designed for bloggers and newsletter publishers, focusing on a 

clean writing experience. 

Joomla 
A middle ground between WordPress's ease of use and Drupal's 

complexity; excellent for social networking or e-commerce sites. 

WordPress.org The world’s most popular publishing platform. It is highly flexible with 

https://en.wikipedia.org/wiki/Content_management_system


thousands of plugins and themes. 

Static Site 

Generators (SSG) 
 

Hugo Fast; it builds websites from plain text files. 

Jekyll 
The engine behind GitHub Pages, widely used for documentation and 

technical blogs. 

Commercial  

Website Builders (Drag-and-Drop) 

Squarespace 
High-quality, professional design templates. It is a closed system, 

meaning it is very stable but less customizable than WordPress. 

Wix 
Features a highly intuitive visual editor that allows you to place 

elements anywhere on a page without coding. 

Enterprise & Professional Tools 

Adobe Experience 

Manager:  

An enterprise-grade solution for large corporations to manage content 

across websites, mobile apps, and forms. 

Webflow:  
A "low-code" tool that bridges the gap between manual coding and 

visual design, popular with professional web designers. 

 

HTML File format settings 

Typical html text as saved by Chordsearch - comments in red 

 

<!doctype html"> 

<html xmlns="https://www.w3.org/1999/xhtml"> 

<head> 

<title>C-major</title> Tab title as shown in web browser display 

<meta name="copyright" content="Created using a copy of Chordsearch for Windows ⌐ 

https://en.wikipedia.org/wiki/Static_site_generator
https://en.wikipedia.org/wiki/Static_site_generator


Giltrex Ltd. All rights reserved."> 

<meta name="cs_version" content="1.40"> Program version saved with 

<meta name="forgrnd_col" content="FFFF80"> Currently not used legacy of java applet 

<meta name="bkgrnd_col" content="C0C0C0"> Currently not used legacy of java applet 

<meta name="font" content="Helvetica"> Currently not used legacy of java applet - see 

note below 

<meta name="wdth" content="6"> Not used legacy of java applet 

<meta name="red_scale" content="no"> Not used legacy of java applet 

<meta name="rwsep" content="2"> Info data below info1..info4 - must not be altered. 

This will break reloading of web page in Chordsearch application. Note 1 

<meta name="info1" 

content="028010C6510B5BF5B00000001246510F5BF5B000000010C6540B5BF5F000000

01246540F5BF5F00000001246140F5BH5F000000021B56B0F5B5BF000000"> 

<meta name="info2" 

content="03129220F5F5BF000000052C49505BF5B5000000052C4AD05BF5F5000000071

AB1B05B5BF500000008148D205F5BF500000008348D20BF5BF5000000"> 

<meta name="info3" 

content="08349920BF5FF500000008148D605F5BFB00000008348D60BF5BFB000000081

499605F5FFB00000008349960BF5FFB000000092B6B50BF5B5B000000"> 

<meta name="info4" content="0A2252C0BF5F5B0000000A22D2C0BFBF5B000000"> 

</head> 

<!-- <cmt> The name for the pdf is taken as the name of this html page. E.g. If 

MyChord.html pdf: MyChord.pdf </cmt> --> 

<body> 

<center><h1 style="color:#FF0000; background-color:#808000; font-family:Verdana;>C-

major</h1></center> Note 2 

<iframe src="C-major.pdf" width="100%" height="800px" style="border: none; "><p>Your 

browser does not support PDFs. <a href = " << "C-major.pdf">Download the PDF</a> 

instead.</p> Note 3 

</iframe> 

</body> 

</html> 

 



  

Note 

1 

If you have no intention of loading this web page back into the Chordsearch 

application for editing, then all the meta name data may be deleted, so that the 

appropriate section will now be: 

<head> 

<title>C-major</title> 

</head> 

Note 

2 

Enable inline style was selected (Tools->Options->HTML Tab dialog), thus colors and 

font specified. Disabled: <h1>C-major</h1> 

Note 

3 

C-major.pdf in this html file must match the name of pdf file previously saved for this 

web page. 

 

 

 

Table of key colour values for HTML 

    

R G B Colour 

00 00 00 Black 

FF 00 00 Bright Red 

00 FF 00 Bright Green 

00 00 FF Bright Blue 

80 00 00 Dark Red 

00 80 00 Dark Green 

00 00 80 Dark Blue 

FF FF 00 Bright Yellow 



80 80 00 Brown 

FF 00 FF Magneta 

80 00 80 Indego 

00 FF FF Bright Cyan 

00 80 80 Turquoise 

FF FF FF White 

80 80 80 Grey 

 

 

Known bugs 

 

Well it is possibly a fact of life that any but the simplest of programs is ever really bug free. 

The best have one or two niggles that are only discovered when the advanced user delves 

into more exotic features, and even then the nature of the bug is not too bothersome, and a 

workaround is often possible. The worse programs on the other hand end up crashing left 

right and centre, with possible loss of data etc. - some these programs should not really be 

worthy of a beta release, and how they ever got past alpha release is a source of 

amazement. I would like to think that Chordsearch tends to the former and is relatively bug 

free. However if you do encounter a problem, please email support and we will investigate 

and certainly get back to you, and let you know our findings.  

 

Check out - Support (Knowledgebase) to find details of known current issues. 

 

See Also 

Appendices 

Appendix B - upgrade to future releases 

https://www.giltrex.com/Support/
https://www.giltrex.com/Support


Screen settings 



Appendix B - upgrade to future releases 

 

Upgrade to future releases via the Net 



Screen settings 

DPI settings for Vista and subsequent Windows versions. 

Background 

Since 2006 high resolution displays have become more common in the marketplace. 

(Previously such displays were rare and costly.) As a consequence, older applications that 

are run on a PC with a high-resolution display setting, resulted in user interface (UI) 

elements smaller than on a PC with a display not capable of such a high resolution. For 

Windows XP, the user when confronted with an application which was difficult to read, 

would often reduce the screen resolution and thus not benefit from the high-resolution 

capabilities for other more up to date applications. 

With the introduction of Windows Vista a feature called DPI virtualisation was introduced to 

provide a level of automatic scaling support for older applications which had been produced 

when lower resolution displays were the norm. Without this feature, the size of text and 

other user interface elements of these older programs would be smaller for a display with 

high DPI settings compared to the rest of the system, thus possibly resulting in usability and 

readability problems. 

DPI virtualisation works by scaling up the application window where there is a higher DPI 

setting. Eg. For a DPI setting of 144, Desktop Windows Manager scales the application 

window by 150% (144/96). This is somewhat of a compromise as although the window and 

UI elements are larger, DPI virtualization is based on pixel stretching and as a consequence 

blurring occurs to the stretched pixels. 

More up to date applications are implemented to be be DPI aware, in that for higher DPI 

settings the applications will scale up accordingly without any disagreeable blurring. 

(Chordsearch from version 1.25 is DPI aware.) 

So for Windows 7, 10 and 11 if you use the control panel Display option to make it easier to 

read what's on your screen* by changing from Smaller 100% default to Medium (125%) or 

Larger (150%) a DPI aware app will scale without any adverse effects. 

Windows 10  

Right click mouse on screen desktop. Select Display settings.  

Scale and layout 



Change the size of text, apps and other items 

Select from dropdown box with standard options 100% 125%, 150%, 175% (Variations on 

percentage size may be set up vis Advance scaling settings.) 

Change DPI Scaling Level for Displays in Windows 10 

Change Display DPI Scaling Level in Windows 11 

 

Appendix 

Dominant PC resolution monitors as of March 2026 

 

  

1920 x 1080 ~ 21 - 23% 

Lower resolutions like 1366 × 768 and 1536 × 864 are more prevalent on budget laptops. 

Statcounter gives an accurate breakdown of current screen resolution statistics 

 

 

 

 

 

 

 

 

 

 

 

 

https://gs.statcounter.com/screen-resolution-stats


See Also 

Appendices 
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Appendix B - upgrade to future releases 



Shareware 

Shareware is a type of software distribution model that allows users to trial the software 

before deciding to purchase it. This model became popular in the 1980s and early 1990s, 

particularly on floppy disks for personal computers. 

In the shareware model, a user can download or obtain a copy of the software at no cost, 

but usually with limitations such as a trial period, limited features, or nag screens that 

remind users to register and pay for the full version. The purpose of these restrictions is to 

encourage users who find the software useful to purchase a license key or full version to 

unlock the limitations. 

The main advantage of shareware is that it allows potential customers to try before they 

buy, reducing the risk of purchasing software that may not meet their needs. This approach 

can also help developers reach a wider audience and gather valuable feedback during the 

development process. 

Some notable examples of popular shareware applications in the past include WinZip, 

Norton Utilities, and Adobe Photoshop. While the popularity of shareware has declined with 

the rise of freeware, freemium models, and subscription-based software, it still remains a 

relevant distribution model for certain types of software today. 

The primary differences between shareware and freeware are that freeware does not have 

any restrictions or limitations on usage, while shareware encourages users to pay for the full 

version after evaluating the trial version. In comparison, freemium models offer basic 

features for free but charge for premium features or additional services. Subscription-based 

software requires a recurring fee to access and use the software, which may include 

updates and customer support. 

 



Freeware 

Freeware software refers to a category of computer programs that are available for use at 

no cost. Unlike other types of software, such as shareware or demo versions, freeware 

does not require payment nor any form of licensing fee. However, it's essential to note that 

while the software itself is free, some developers may still ask for donations to support 

further development and maintenance. 

Freeware differs from open-source software in that the source code isn't necessarily 

available for public viewing or modification. While some freeware programs may have their 

source code accessible, others are distributed as closed-source applications. 

Freeware is often created by individual developers or small teams of enthusiasts who share 

their creations with the online community. This type of software can range from simple tools 

to complex applications, covering various fields like productivity, gaming, graphics design, 

and more. Some examples include VLC Media Player, GIMP, and 7-Zip. 

Downloading freeware software usually comes without legal restrictions, but it's important 

for users to be cautious when acquiring these programs from unverified sources. Some 

malicious software may disguise themselves as freeware to trick unsuspecting users into 

downloading potentially harmful files. As a result, it's always recommended to only obtain 

freeware from reputable websites or developers to ensure the software is safe and reliable. 



Open source software 

Open Source Software (OSS) refers to a type of software whose source code is publicly 

available for anyone to inspect, modify, and distribute. This transparency sets OSS apart 

from proprietary software, where the source code is kept secret. The philosophy behind 

OSS is collaboration: developers from around the world can contribute to its development, 

resulting in continuous improvement through collective effort. 

The Open Source Initiative (OSI) is a non-profit organization that defines open source and 

sets standards for licensing open source software. One of the most common licenses used 

is the GNU General Public License (GPL), which requires any derivative work to also be 

open source. 

Benefits of using OSS include cost savings, as it's often free to use and modify; flexibility, 

as users can customize the software to meet their specific needs; and a robust community 

of developers contributing to its maintenance and updates. However, because of its 

decentralized nature, OSS may not have the same level of support or commercial backing 

compared to proprietary software. 

Notable examples of open source software include Linux (an operating system), Apache (a 

web server), and Python (a popular programming language). While some companies offer 

support services for OSS, it's important for users to understand the implications of using a 

particular open source license before adopting it for their projects. Overall, open source 

software plays a vital role in fostering innovation, collaboration, and accessibility in the 

technology industry. 



Chordsearch Notes Page 

The following options enable the look up of a chord: 

 

  

Notes 
Check the notes that are to make up the chord. A maximum of 6 

can be checked. 

Clear 
Clear all notes checked. The notes from a previous search are 

retained on entry to the dialog. 

Add 
Allows the addition of the chord to the user directory. (Enabled 

when no chord id found.) 

Clear previous selection 

on initialisation 

When NOT checked on subsequently entering the dialog box the 

notes from the previous search are retained. 

 

OK. and Cancel pushbuttons 

    



Chord Directory dialog box 

The following options enable the look up of a chord: 

  

Chord List box listing all chords in the directory for a particular root. 

Up 
Go to root above e.g. If Ab major, G# minor etc. is displayed - will change to A 

major, A minor etc. 

Down 
Go to root below e.g. If Ab major, G# minor etc. is displayed - will change to G 

major, G minor etc. 

OK 
On highlighting a particular chord, selecting OK will display the chord.  

Shortcut: Double click on the chord name. 

Short 

names 
Select this check box to display the chord names in abbreviated format. 

OK. and Cancel pushbuttons 

    



User Directory dialog box 

The following options enable the look up/addition/modification of a custom chord: 

  

Notes Displays constituent notes on highlighting a custom chord. 

Add 
Selection enables addition of a chord by Add New Chord to User Directory dialog 

box 

Modify 
Selection enables modification of a chord by Modify Chord in User Directory dialog 

box 

Delete 

Deletes the highlighted chord from the custom directory. Note this is irreversible. 

The Cancel push-button will not abandon any changes made whilst in this dialog 

box. 

OK 
On highlighting a particular chord, selecting OK will display the chord.  

Shortcut: Double click on the chord name. 

Cancel Exit dialog box without selecting any chord. 

 

Tip: shortcut for adding "No Chord id Found" chord to the User Directory: Place cursor on 

"No Chord id Found" title and use the pull right menu to launch Add New Chord to User 

Directory dialog box. 

 



Copy to Scratch Pad command (Edit menu) 

Use this command to copy marked chords into the Scratch Pad.  

Whilst in normal chord display (View-> Scratch Pad off and View-> Fretboard off) mark the 

chords that you wish to copy (Ref.: Marking display to copy to Clipboard and Scratch Pad 

etc. ) then select Copy to Scratch Pad from the Edit menu to transfer the marked chords to 

the Scratch Pad. 

Copying chords to the Scratch Pad will append chords to any current chords already stored 

in the Scratch Pad. The maximum number of chords that can be stored in the Scratch Pad 

is 36. (Note: all 36 can only be viewed when on size setting 6). If the Scratch Pad is full the 

chords will not be copied. 

Shortcut 

Toolbar:  

 

Keys: CTRL+R 



Editing Attributes of Scratch Pad Chords 

Whilst in the Scratch Pad display (View-> Scratch Pad on) mark the chord that you wish to 

edit (Ref.: Marking display to copy to Clipboard and Scratch Pad etc.) then select Attributes 

of Scratch Pad chord from the Edit menu to display the Scratch Pad Chord Attributes dialog 

box.  

(Shortcut: Left double click mouse button above chord frame.) which allows the setting of 

the various attributes of the chord. 

 

 

 

 



General Page 

The General Page allows set up of History, plus reduced span. 

  

History  

Include 

Select to activate the history buffer. This allows the facility to go through previously 

selected Chord Pages, by the use of the Forward and back button. Similar 

operation to that on a typical web browser such as IE or Firefox. Note: History 

option is not applicable when in Scratchpad mode. 

Buffer 

size 

Set size of chord page buffer. May be set from 10 chord pages through to 200 

chord pages. 

 

  

Filter  

Reduced 

Span 
Use this option to reduce the span of the chords selected. 

Shortcut 

The chord displays for up to and including the 7th fret position cover a maximum 

span of 4 frets. Past the 7th fret position the chord displays cover a maximum 

span of 5 frets. Select this option should you wish to reduce the respective spans 

by 1 fret (i.e. Up to and inc. 7th fret maximum span = 3 frets; past 7th fret 

maximum span = 4 frets). 

Toolbar:  

 
 

 

  

Updates  

Check for updates Select to automatically check every 7 - 60 days for any updates to the 



current installed version.  

Check Now Check if any update is available now. 

Check Now 
Displays current installed version and latest version when last 

checked 

Go to download page 

for version.. 

If an updated version is available this push button will be enabled and 

will launch your web browser to open the download page. 

The button will be disabled if the current installed version is equal to 

the available version when last checked. 

 

Notes on Updates: 

1. This is a simple check and after notification of any update, you will need to download the 

new version, exit your existing version and install the new version over the existing version. 

2. By default this option is switched off. If switched on and it finds an update then a 

Message Box will be displayed. If you choose not to download and install the update, fine; 

you will not be notified of the update for another set number of days (assuming that the 

"Check for updates" box is selected). 

3. If on launching the program and an outstanding update is detected then the General tab 

will have an asterisk displayed: General* 

 

OK. Cancel and Apply pushbuttons 

    



Display Page 

The Display Page allows set up of presentation. 

 

  

Notes 

Colour 

Tick this command for separate colours for each distinct note. i.e. A - dark blue, 

A#/Bb - bright blue etc. 

Notes on 

Frets 

Tick this command to have the notes displayed on the fretboard for the chord grid 

as opposed to the more usual finger position circles on the frets with the notes 

shown at the bottom of the chord grid.  

Note: For viewing the fretboard, the notes are always displayed on the fretboard. 

Font Title Select the font style for the main title 

Filter 

Fonts 

Limits fonts to more common fonts. (Excludes symbol fonts etc. for a cleaner and 

less cluttered font dialog interface allowing an easier choice and selection.)  

 

OK. Cancel and Apply pushbuttons 

    



Language Options dialog box 

In German speaking nations different symbols are used for some notes, e.g. A# reads Ais 

etc., as shown in the table below: 

 

   

Name English symbol German symbol 

A flat Ab As 

A sharp A# Ais 

B flat Bb B 

B B H 

C sharp C# Cis 

D flat Db Des 

D sharp D# Dis 

E flat Eb Es 

F sharp F# Fis 

G flat Gb Ges 

G sharp G# Gis 

 

The following option allows the use of German note names: 

German Note symbols - Select checkbox. 

Uses German note symbols for the chords displayed. 

 



Change Tuning Page 

The following options allow the setting and control of a particular tuning configuration: 

 

  

Enable sounds on adjusting tuning 

checkbox. 

While adjusting the tuning the note is 

sounded. 

6th, 5th.. push-buttons Sound the individual note. 

 

Spin buttons 

Press up to raise the note and down to lower the note. The notes wrap round - that is you 

can set each note 3 steps (6 frets) in pitch above its regular tuning and 2.5 steps (5 frets) 

below its regular tuning. For example - For E on the sixth and first string it can be set up to 

A# before it wraps round and goes down to B. 

 

    

Setting    

String lowest  Regular highest 

6th B E A# 

5th E A D# 

4th A D G# 

3rd D G C# 

2nd F# B F 

1st B E A# 

 



Set Regular 

Sets tuning to regular. 

On changing the tuning and then selecting OK the modified tuning is in effect as displayed 

on the status bar. [Tuning: Standard (E A D G B E)] 

Set Open A, C, D, E, G 

Sets tuning to Open A, C, D, E, or G 

This button allows the set up of a standard open tuning - namely Open A, C, D, E, or G. The 

push-button will either display 'Select Open A', 'Select Open C', 'Select Open D', 'Select 

Open E', or 'Select Open G'.  

If the tuning has been set to Open A then the text 'Open A' will be displayed in the upper 

portion of the dialog box and the push-button will be labelled 'Select Open C'. On selecting 

Open C as well as the tuning changing to open C the text 'Open C' will be displayed and the 

push-button will be labelled 'Select Open E' - i.e. the push-button toggles through the open 

tuning settings available. 

For example: If setting the tunng to Open A, the modified tuning will be displayed on the 

status bar. [Tuning: Open A (E A E A C# E)] 

 

 

OK. Cancel and Apply pushbuttons 

    



Cut chords from Scratch Pad 

Whilst in the Scratch Pad display(View-> Scratch Pad on) mark the chords that you wish to 

cut (Ref.: Marking display to copy to Clipboard and Scratch Pad etc.) then select Cut from 

Scratch Pad from the Edit menu to remove marked chords from the Scratch Pad. 



Scratch Pad Page 

The following options allow the setting up of the Scratch Pad preferences: 

Display Page Title checkbox. 

Displays the Page Title for the Scratch Pad.  

Default to Display Chord Titles on saving to Scratch Pad checkbox. 

On saving chord(s) to the Scratch Pad a chord title is saved. The title is based on the chord 

name. This of course can be modified later by selecting  Attributes of Scratch Pad from the 

Edit Menu. 

Display Chord Title at bottom of chord frame checkbox 

Displays the Chord Title (if selected) at the bottom of the chord frame rather than the top. 

Justification. 

Displays the Chord Title (if selected) to the left / centre or right of the chord grid. 

Set All Chord Titles in Active Scratch Pad checkbox. 

Tick this check box if you wish to override all settings for hide/display chord title. i.e. If you 

have chosen to not display some Chord Titles in the Scratch Pad, ticking this checkbox and 

setting the radio button to Display will display all chord titles for the chords in the Scratch 

Pad (assuming that titles have previously been set up). Conversely setting the Hide radio 

button will hide all chord titles. 

Chord Title Font pushbutton. 

Select the font style for the chord titles. 

Filter Fonts checkbox. 

Limits fonts to more common fonts. (Excludes symbol fonts etc. for a cleaner and less 

cluttered font dialog interface allowing an easier choice and selection.) 

OK. Cancel and Apply pushbuttons 

    



Saving Display to HTML file 

Choose Save As HTML from the File menu to save the current display to an HTML file. On 

selecting this option a standard Save As dialog box is displayed.  

The following options allow you to specify the name and location of the file you're about to 

save: 

 

  

Save In 
Select a folder to save the file in. You can select network paths, computers, drives, 

directories, and folders. 

File 

Name 

Type a new/modified filename for to the one suggested. Note If you type a pattern 

using a wildcard (* or ?) in the File Name box and press ENTER, the list box 

displays files matching that pattern in the selected folder. 

Save As 

Type 

Select a file type from the drop-down list box. The filename extension determines 

the file type of the saved file. Default id *.html 

Save Saves the designated file. 

 

Note: When saving from a chord display with more than one page, only the active page will 

be saved. 



Load HTML to Scratch Pad (File menu) 

Use this command to load a previously saved HTML page into the Scratch Pad.  

It should be noted that the page is loaded into Chordsearch with the current options set up 

in Chordsearch taking precedence over the options saved in the HTML page. That is if you 

previously saved a display of six chords, displaying on your browser as a 3 grid width, 

colour setting: black on a white background etc., then if the current settings in Chordsearch 

are grid width 6 and colour setting blue on green etc., then after editing and saving the 

HTML page the current HTML Format and Size settings will apply. 



HTML Format Page 

The following options allow the setting of the HTML text if Enable inline style is selected. 

Otherwise the html font and colors will be derived from the default settings for your website 

Chordsearch Html Font. 

Select Html Font to be written to any html files saved by Chordsearch. (Enable inline style 

[x]) 

 

  

Colour Settings:  

Text Allows the setting of the text colour. 

Background Allows the setting of the background colour. 

Default Set text and background to default - black on grey. 

Note: On setting a colour, theoretically you have a choice of 16 million colours. However, 

web designers often work with a limited color palette for better accessibility and readability. 

They might use predefined color systems like HSL (Hue, Saturation, Lightness), 

hexadecimal color codes, or color libraries to ensure their designs are visually appealing yet 

easy on the eyes. 

. 

Enable inline style: 

When selected then the above Font and color settings are apploed to any html files saved 

by Chordsearch.. 

Include Language tag 

This adds the relevant language tag to be written to any html / shtml files saved by 

Chordsearch. E.g. If locale detected as Australia, US, NZ etc. will write <html lang="en"> 

rather than <html> if not selected. 

Supported locale languages: 

English "en", German "de", French "fr", Spanish "es", Italian "it", Polish "pl", Portuguese "pt", 

Dutch "nl", Swedish "sv" 



 

OK. Cancel and Apply pushbuttons 

    



MIDI Out Page 

The following options allow the selection of a particular output device: 

Output device combo box. 

Select an output device available on sound card. 

Technology 

Type of the MIDI output device.  

Number of Voices 

Voices supported by an internal synthesizer device. *  

Number of simultaneous notes 

Number of notes that can be played simultaneously by an internal synthesizer device.* 

Features 

Other features. 

*If device selected is a port, field has no meaning and will be set to 0. 

OK. Cancel and Apply pushbuttons 

 

    



Copy to Clipboard command (Edit menu) 

Use this command to copy marked region into the clipboard.  

Copying data to the clipboard replaces the contents previously stored there. 

Shortcuts 

Toolbar:  

 

Keys: CTRL+C 

 



File Save As HTML command 

 

Use this command to save and name the active document. Chordsearch displays the Save 

As dialog box so you can name your document.  



Print command (File menu) 

Use this command to print a document. This command presents a Print dialog box, where 

you may specify the range of pages to be printed, the number of copies, the destination 

printer, and other printer setup options. 

For web publishing select Microsoft Print to PDF, followed by Save As HTML. The PDF 

output file can then be linked to the HTML file output. (Ref.:Publishing your chords on the 

web.) 

 

Shortcuts 

Toolbar:  

 

Keys:  

CTRL+P 



Print Preview command (File menu) 

Use this command to display the active document as it will appear when printed. When you 

choose this command, the main window will be replaced with a print preview window in 

which one or two pages will be displayed in their printed format. The print preview toolbar 

offers you options to view either one or two pages at a time; move back and forth through 

the document; zoom in and out of pages; and initiate a print job. 

Shortcuts 

Toolbar:  

 



Print Setup command (File menu) 

Use this command to select a printer and a printer connection. This command presents a 

Print Setup dialog box, where you specify the printer and its connection. 

Note: For Fretboard the Print Setup defaults to Landscape. 



File Exit command 

Use this command to end your Chordsearch session. You can also use the Close command 

on the application Control menu. 

Shortcuts 

Mouse: Click the application's Close button. 

 

Keys: ALT+F4 



Cut From Scratch Pad command (Edit menu) 

Use this command to cut the marked chords from the Scratch Pad.  

Shortcut 

Toolbar:  

 

 



Attributes of Scratch Pad Chord command (Edit 

menu) 

Use this command to edit the attributes of the marked chord in the Scratch Pad. This 

command presents a Scratch Pad Chord Attributes dialog box, where you may set the 

various attributes of the chord. 

 

Shortcut 

Left double click mouse button above chord frame. 

 



Chordsearch command 

Use this command to search for a chord using either: 

Notes Page, where you may look up a chord by entry of constituent notes. 

Diagram Page, by marking up a chord diagram. 

 

Shortcuts 

Toolbar:  

 

 



Chord Directory command 

This command presents a Chord Directory dialog box, where you may look up a chord listed 

in the standard directory. 

Shortcuts 

Toolbar:  

 

 



User Directory command 

This command presents a User Directory dialog box, where you may look up /add / modify 

/delete a chord in your custom directory. 

 



Toolbar command (View menu) 

Use this command to display and hide the Toolbar, which includes buttons for some of the 

most common commands in Chordsearch, such as Chord Directory. A check mark appears 

next to the menu item when the Toolbar is displayed. 

See Toolbar for help on using the toolbar. 



Status Bar command (View menu) 

Use this command to display and hide the Status Bar, which will display the action of a 

selected menu item or toolbar button, plus chord selected, inversions, tuning status and 

keyboard latch state. A check mark appears next to the menu item when the Status Bar is 

displayed. 

See Status Bar for help on using the status bar. 



Chord Display command (View menu) 

Use this option to view chords looked up.  

Note: if no chord has been selected (i.e. not shown in Window Title or Status Bar) the 

screen will be blank. 

Note: Scratch Pad must be off. Ref.: Scratch Pad  

Shortcut 

Toolbar:  

 (Up) 

 



Fretboard command (View menu) 

Use this option to view the Fretboard. 

Note: if a chord is selected (i.e. shown in Window Title and Status Bar) the fretboard will 

show only the notes for that chord. Use Clear to view all notes. 

Note: Scratch Pad must be off. Ref.: Scratch Pad  

Also for printing the Print Setup Dialog defaults to Landscape. 

Shortcut 

Toolbar:  

 (Down) 

 



Scratch Pad command (View menu) 

Use this option to view the Scratch Pad. 

Note: On selecting Scratch Pad Search, Change Tuning, Reduced Span are disabled.  

Shortcut 

Toolbar:  

  

(Scratch Pad: Pressed down, Normal display: Up) 

 



Clear command (View menu) 

Use this option to clear the active screen display.  

In the case of viewing the Chord display: 

  

 
If the history buffer is empty - then the screen will clear. Otherwise the display will drop 

back to the chord in the history buffer prior to the one just cleared. 

 In the case of viewing the Fretboard display: 

 

If the history buffer is empty - then the screen will show all notes on the fretboard. 

Otherwise the display will drop back to the chord in the history buffer prior to the one just 

cleared. 

 Scratch Pad: the screen will clear.  

Shortcut 

Toolbar:  

  



Back command (View menu) 

Use this option to move back to the previous chord stored in the chord history buffer. 

Note: Chord History Buffer is set up via General Page accessed through Tools -> Options  

Shortcut 

Toolbar:  

  



Forward command (View menu) 

Use this option to move forward to the previous chord stored in the chord history buffer. 

Note: Chord History Buffer is set up via General Page accessed through Tools -> Options  

Shortcut 

Toolbar:  

  



Start History command (View menu) 

Use this option to move to the first chord stored in the chord history buffer. 

Note: Chord History Buffer is set up via General Page accessed through Tools -> Options  



End History command (View menu) 

Use this option to move to the last chord stored in the chord history buffer. 

Note: Chord History Buffer is set up via General Page accessed through Tools -> Options  



First Page (View menu) 

For chord displays which consist of more than one page, sets the view to the First Page. 

Shortcut 

Toolbar:  

  

 



Previous Page (View menu) 

For chord displays which consist of more than one page, sets the view to the Previous 

Page. 

Shortcut 

Toolbar:  

  

 



Next Page (View menu) 

For chord displays which consist of more than one page, sets the view to the Next Page. 

Shortcut 

Toolbar:  

  

 



Last Page (View menu) 

For chord displays which consist of more than one page, sets the view to the Last Page. 

Shortcut 

Toolbar:  

  

 



Size command (View menu) 

Use this command to set the scale sizing. This command presents a Size dialog box, where 

you may set the size to 3, 4, 5 or 6 width Chord displays. 

Shortcut 

Toolbar:  

 

 



Language Options 

Use this command to select or deselect German Language preference for the display of 

note symbols. This command presents a Language Options dialog box, 

 



Options command (Tools menu) 

Use this command allows set up various options for Chordsearch. via the tabbed dialog with 

the following Pages:  

Display  

General  

Tuning  

Scratch Pad 

HTML 

Sound  

MIDI Out 

 



Contents and index command (Help menu) 

Use this command to display the Contents, Index and Find dialogs for Help. From the 

opening screen, you can jump to step-by-step instructions for using Chordsearch and 

various types of reference information.  

Once you open Help Contents, you can click the Contents button whenever you want to 

return to the opening screen. 

Index allows searching of words indexed in Chordsearch help. 



Donate (Help Menu) 

Opens a web browser for the Chordsearch donation page. 



About command (Help menu) 

This command presents an About dialog box. 

 



Sound Page 

The following options allow the setting up of the instrument and its characteristics for the 

sound card: 

Instrument 

Select instrument. 

Velocity 

Attack - How hard the string / key is hit. 

Note Duration 

Length of time that the note will sound for. If the instrument selected is an acoustic guitar, 

the sound will fade after 2 seconds anyway - so setting note duration to 8 seconds as 

opposed to 2 seconds will have no noticeable effect. However for an instrument such as a 

Hammond Organ the sound will cut after set time interval. 

Note Separation 

On playing a chord on a guitar, if playing the chord with a downstroke there is a time 

difference between playing the 6th string and 5th string etc. through to the 1st string, 

dependant on the speed of the stroke, use this setting for your preference. If the instrument 

selected is a piano then it is normal to set this to 0. 

Default 

Select default settings: Instrument - Acoustic Guitar, Velocity - 64 (scale 1 - 127), Note 

duration - 2500ms(2.5 seconds), Note separation - 30 ms. 

Test 

If a chord has been selected (displayed in caption bar) then this button will sound the first 

inversion of the chord. If no chord is selected open E major will sound. 

OK. Cancel and Apply pushbuttons 

    



Upgrade to future 1.xx releases via our 

homepage 

Future releases may be downloaded from: 

www.chordsearch.com 

 

 

 

https://www.chordsearch.com/


Add New/Modify Chord to User Directory dialog 

box 

The following options enable the addition/modification of a chord: 

  

Chord 

Name 
Name of the chord. 

Notes Check the notes that are to make up the chord. A maximum of 6 can be checked.* 

Clear Clear all notes checked.  

OK Confirm. 

* 

Note: For the instance where this Dialog has been selected from the Chordsearch 

(Notes or Diagram) Dialog, then all the notes are disabled, the only requirement 

being to supply a name. When selected using the pull right menu on the "No chord 

id found" title all notes are disabled with the exception of any sharp / flat 

combintions where you have the option to change an C# to Db etc. 

 



Scratch Pad Chord Attributes dialog box 

The following options allow the setting of the Chord attributes. 

Display Page Title checkbox. 

Displays the Page Title for the Scratch Pad as described by the edit field.  

Display This Chord Title checkbox. 

Displays the Chord Title for this chord as described by the upper and lower edit fields.  

Chord Frame 

The radio buttons in the chord frame allow easy changing of finger positions for the chord. 

On changing the finger positions the note is automatically updated to reflect the new 

position. Using the fret spin button, the fret position can be changed from 0 through to 11, 

automatically updating the notes at the bottom of the frame. When set at 0 this represents a 

chord for which open strings are played, this being the only case for which the open strings 

are enabled. 

Accidental buttons 

For the case where the note is a sharp or a flat, the note may be changed - e.g. if wishing to 

change C# to Db press the button below the appropriate note. This will result in every C# 

changing to Db. for the chord. 

Mark with X 

Mark the note with an X to indicate that the string is muffled , i.e. finger leaned on the string. 

For example in the chord diagram below the third finger leans lightly on the fifth string.  

 

Finger Position 

Use the appropriate finger spin buttons to display the suggested fingering for the chord.  

Finger position 5 displays a 'T' (thumb). 

OK. and Cancel  pushbuttons 

 

    



File Save As dialog box 

 

The following options allow you to specify the name and location of the file you're about to 

save: 

  

Save In 
Select a folder to save the file in. You can select network paths, computers, 

drives, directories, and folders. 

File 

Name  

Type the new filename for this file. Note: If you type a pattern using a wildcard (* 

or ?) in the File Name box and press ENTER, the list box displays files matching 

that pattern in the selected folder. 

Save As 

Type 

Select a file type from the drop-down list box. The filename extension determines 

the file type of the saved file. Default id *.html 

Save  Saves the designated file. 

 

 

 

 

 

  

 



Chordsearch Diagram Page 

The following options enable the look up of a chord by marking up a chord diagram: 

 

Picture Box displaying chord diagram 

The picture box allows you to set up a chord diagram and use this to look up a chord. To 

put in finger position markers, ensure that the finger marker is selected, then line up the 

cursor on the appropriate string and fret position and click the left hand mouse button - a 

finger position will now be drawn on the appropriate string and fret position that you clicked 

on.  

 

  

Marker Allows selection of appropriate tool for marking chord diagram. 

  
Select the finger position marker tool for inserting a finger position in the chord 

diagram. 

 

Select the erase marker tool for deleting a finger position marking in the chord 

diagram. (Note: If you wish to move the finger position marking from e.g. 1st to 2nd 

fret, then click on 2nd fret position with the finger position marker tool.) 

Bottom 

row 

Displays the notes of the chord selected.  

E.g. If open E - displays: E B E G# B E 

 

  

Show fret number spin control  Displays fret number alongside chord diagram.  

 

  

Tuning 
Displays the tuning selected as set up in the Change Tuning 

Page. 



Add 
Allows the addition of the chord to the user directory. (Enabled 

when no chord id found.) 

Clear previous selection 

on initialisation 

When NOT checked on subsequently entering the dialog box the 

notes from the previous search are retained. 

 

OK. and Cancel pushbuttons 

    



Toolbar 

 

 

The toolbar is displayed across the top of the application window, below the menu bar. The 

toolbar provides quick mouse access to many tools used in Chordsearch, 

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T). 

  

Click To 

 Move back to the previous chord stored in the chord history buffer. 

 Move forward to the previous chord stored in the history buffer. 

 Chordsearch 

 Chord Directory. 

 Display fretboard view, otherwise Chords view displayed. 

 Display Scratch Pad view. 

 Reduce chord span. 

 Cut marked chords from Scratch Pad. 

 Copy marked chords to the Scratch Pad. 

 Copy marked region to the clipboard. 

 Clear the active chord screen display  

 Print the active document. 

 Print preview. 

 View first page of chord display. 



 View previous page of chord display. 

 View next page of chord display. 

 View last page of chord display. 

 
Context sensitive help - On running Chordsearch by clicking on this button and 

selecting a menu item or toolbar button the appropriate help section will appear. 

 Display the copyright notice and version number of Chordsearch. 

 

 

 

 

 

 

 

 



Status bar 

 

 

The status bar is displayed at the bottom of the Chordsearch window. To display or hide the 

status bar, use the Status Bar command in the View menu. 

The left area of the status bar describes actions of menu items as you use the arrow keys to 

navigate through menus. This area similarly shows messages that describe the actions of 

toolbar buttons as you depress them, before releasing them. If after viewing the description 

of the toolbar button command you wish not to execute the command, then release the 

mouse button while the pointer is off the toolbar button. 

The next area displays the chord name currently selected. 

The next area displays the Tuning status plus the number of inversions of the chord 

currently selected, plus the page number. 

The right areas of the status bar indicate which of the following keys are latched down: 

 

  

Indicator Description 

CAP The Caps Lock key is latched down. 

NUM The Num Lock key is latched down. 

SCRL The Scroll Lock key is latched down. 

 

 

 

 

 



Size dialog box 

The following option allows the setting of the scale sizing. 

Scale  

Select 3, 4, 5 or 6 width Chord displays. 

 



About Dialog box 

Displays the version number of your copy of Chordsearch and system information, plus a 

link to Chordsearch (Giltrex) website. 

 


